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Orcad Layout Plus Tutorial

Layout Plus is a circuit board layout tool that accepts a layout-compatible circuit
netlist (ex. from Capture CIS) and generates an output layout files that suitable for PCB
fabrication. This tutorial is the second part of PCB project tutorial. Before start with
Layout Plus, you need to have a complete netlist of your design, if you do not have it yet,
please read the first part on “Capture CIS Tutorial”.

Simple steps in producing PCB layout involve importing netlist, placing
components, routing and generating output files and reports. For more information about
Layout Plus, please refer to Layout Help (From Layout Plus menu, go to Help = Layout
Help)

Opening Layout Plus and Creating New Design

To open Layout Plus, from Windows Start Menu, select Program - Cadence
PSD 15.0 = Layout Plus. Go to File = New to create a new design. You will see the
dialog as shown in figure 1. Enter the default technology template located on
C:\Cadence\PSD_15.0\tools\layout_plus\data\ default.tch in “Input Layout TCH”
textbox. Enter the netlist (generated from Capture CIS) of your design in “Input MNL”
textbox. And then enter the location and file name that you want the design file to be
saved in “Output Layout” textbox. (You might want to save it on your network drive if
you’re running Capture CIS in campus’s laboratory). Layout Plus will give the output
layout file name as same as the input netlist file by default. If you change the output file,
do not change the output file extension (.max). Then click Apply ECO.

Layout Plus will display the dialog shown in figure 2 after you apply ECO. In
case of footprint linking error (missing footprints on some components), you will need to

Univerisity of Maryland, Baltimore County (UMBC) 1



CMPE 310
Fall 2006 Layout Plus Tutorial Ekarat Laohavaleeson

give the footprints to all missing components to complete AutoECO. (As explained in
Capture CIS tutorial, it is better to specify footprints to all parts during schematic
creation.) Hit “Accept this ECO” to import the netlist into Layout Plus. Figure3 shows
the Layout Plus window after importing a netlist.

| ¥ AutoECO

File Mames

Input Layout TCH or TPL or M& file FEL =

=1
ACadence P50 _15. 0% oolshayaut_pluzhdatah_default tch
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[nput MHL netlist file

SAEENCMPE 310 TAMutarialhlayouthexample filez\CMPEIT0MML

Clutput Layout ké= file
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Ay special switches given bo pou by Cadence Customer Suppoart

AutoECO &pply ECO Help Cancel

Figure 1: New Design Dialog
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| ¥ AutoECO

This repart was viritten ta file 'E:AKEVCMPEST0_TAATUTORIAL\LAYOUTAEXAMPLE FILESNCMPES10-1.LIS
AutoECO Repart

FILE-&; C:ACADEMCESPSD_15.0M\TOOLSALAYOUT _PLUSADAT AN _DEFAULT.TCH
FILE-B: E:\AKENCMPEZ0_TAATUTORIALALAYOUTAERAMPLE FILESSCRMPE 310.MML
IE"*EOF*" immediately follows, no changes were made

Adding footprint DIP.100/2054 300401 025

Adding footprint WalL COM.100/RH /T 20E A4 550420

Adding footprint DIP.100/405¢ B00/L2. 025

Adding package 74L5373

Adding package HEADER_10<2

Adding package S8086kIMN

Adding component U5

Adding component LB |-
Adding component J1

Adding component U7

Adding component U8

Adding net &7

Adding net ADZ

Adding net AD10

Adding net NEEEEE5

Adding net 013

Adding net A0 4

Adding net ATE

Adding net A0 8

Adding net 418

Adding net A0

Adding net NS5EEDS

Adding net &0 7
Addina ket A11 hal
<TI | 3

Accept thiz ECO

| v

Discard this ECO |

Figure 2: Dialog after applied ECO

@ More info:

- ECO (Engineering Change Order) is Layout Plus command that provide an
ability to forward and back annotate your design flow. The forward annotate
let you forward the change of your netlist (ex., from Capture CIS schematic)
to the PCB. The back annotate just do the opposite, export the change of your
design in PCB back to the schematic.

- You can set different options for AutoECO, the tool will update particular
properties of the design according to the setting.

- Technology template (we are using _default.tch in this tutorial) contains
information regarding layout design such as board layers, spacing, track
widths, design rules, etc. Creating your own template is helpful in making a
number of designs with the same set of rules and settings however it is out of
this tutorial’s scope.
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™ Layout Plus — E:\AKEYCMPE310_TA% TUTORIAL'LAYDUTEXAMPLE FILES:CMPE310-1.MAY
File Edit Wiew Tool Options Auto  ‘Window Help

=|=wl =|nlE| 222(0] oW o@IT]:cf _IIW_I _I_I | E4 B

X [2800 v |-2300 G 100 [1_TOE

rﬂ' Design - Component Tool {(DRC ON})

Figure 3: Layout Plus Window after importing netlist

Setting Design Environment

To set the design environment (display unit, grids, rotation, snap) go to Options
- System Settings. Modify the setting that suitable for your design. Figure 4 shows the
system setting dialog.

Next, you will need to define the layer stack for your design, go to View >
Database Spreadsheets - Layers. From here, specify layer type and mirror layer
(usually the most outer layers, TOP and BOTTOM, are the mirror layers of each other).
An example of layer stack for 4-layer board design (TOP, BOTTOM, POWER and
GND) with POWER and GND layers as power and ground plans and TOP and BOTTOM
as routing layers is shown in figure 5.
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System Settings I
~Display Units —Grids
&+ Mils [m] Aer . .
Yisible grid [<.Y]: ||]
" Inches [in]

" Microns [u] Detail grid [X.]: |25

 Millimeters [mm)
" Centimeters [cm) Place grid [X.¥]: 100

Display Resolution: Routing grid: IEE—
|1' Via grid: |25

Rotation

Increment; q0 Snap: o1’

YWorkspace Settings...

0K | Help | Cancell

Figure 4: System Settings

After modify layer stack, you will need to specify routing spacing (Options >
Global Spacing), you can modify track-to-track, track-to-via, track-to-pad, via-to-via,
via-to-pad, and pad-to-pad spacing according to the capabilities of preferred PCB
manufacturer. (for example, www.pcbexpress.com ). Figure 6 shows all routing spacing
set to 6 mil.

There are many other parameters that you can set and should be carefully checked
with the recommended parameters from PCB manufacturer (drill sizes, padstacks,
minimum track width, etc.) In this tutorial we will use all default parameter values. If you
plan to fabricate your boards, please consult the PCB manufacturer.

Q More info:

- Mil unit is commonly used in PCB footprint and PCB board design.
- 1 mill = 0.001 inch
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Layer Layer Layer Layer Mirror
Name Hotkey NickName Type Layer
TOP 1 TOP Routing BOTTOM
BOTTOM 2 BOT Routing TOP
GND 3 GND Plane [Noneg)
POWER L PYWR Plane [Noneg)
INNER1 5 IN1 Unused [Noneg)
INNER2 6 IN2 Unused [Noneg)
INNER3 7 IN3 Unused [Noneg)
INNERA 8 IN4 Unused [Noneg)
INNERG 9 INS Unused [None)
INNERG Ctrl + 0 ING Unused [None]
INNER7? Ctrl +1 IN7 Unused [None]
INNERS Ctrl + 2 ING Unused [None]
INNERS Ctrl + 3 IN9 Unused [None]
INNER10 Ctrl + 4 110 Unused [None]
INNER11 Ctrl +5 111 Unused [None]
INNER12 Ctrl + 6 112 Unused [None]
SMTOP Ctrl + 7 SMT Doc SMBOT
SMBOT Ctrl + 8 SMB Doc SMTOP
SPTOP Ctrl + 9 SPT Doc SPBOT
SPBOT Shift + 0 SPB Doc SPTOP
S3TOP Shift + 1 aaT Doc S3B0OT
S3BOT Shift + 2 S3B Doc S3TOP
ASYTOP Shift + 3 AST Doc ASYBOT
ASYBOT Shift + 4 ASB Doc ASYTOP
DRLDWG Shift + 5 DRD Doc [None]
DRILL Shift + b DRL Drill [None]
FABDWG Shift + 7 FAB Doc [None]
NOTES Shift + 8 NOT Doc [None]
Figure 5: 4-layer board with power and ground planes setting
Layer Track to Track to Track to Via to Via to Pad to
Name Track Via Pad Via Pad Pad
TOP 6 6 b b 6 b
BOTTOM 6 6 b b 6 b
GND 6 6 6 6 6 6
POWER 6 6 b b 6 b
INNER1 G G 6 6 G 6
INNER?Z 6 6 6 6 6 6
INNER3 6 6 b b 6 b
INNERA G G 6 6 G 6
INNERS 6 6 6 6 6 6
INNERG 6 6 b b 6 b
INNERY G G 6 6 G 6
INNERS 6 6 6 6 6 6
INNERS 6 6 b b 6 b
INNER10 G G 6 6 G 6
INNER11 6 6 6 6 6 6
INNER1?2 6 6 b b 6 b
DRILL G G 6 6 G 6

Figure 6: Routing Spacing
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.
<~ Tips:
- Easy access to various designs setting by clicking on [=] button on the
toolbar.

- Easier to work on your design by Disable Online DRC by clicking on g
button on the toolbar

Creating Board Outline

Board Outline is the outline for all components and net routings of your PCB. To

create board outline, click on Obstacle Tool B2 on the toolbar or go to Tool = Obstacle
-> Select Tool. Then double click on one corner point you want to make an outline, the
Edit Obstacle dialog will popup, set obstacle type to “Board Outline” and obstacle layer
to “Global Layer” as shown in figure 7.

Edit Obstacle |

Obstacle Name IE

Obstacle Type

Board outline

Group Height Width

Obstacle Layer
IGlDbal Lavyer

—Copper Pour Rules

Clearance I Z order,

Mote: Use Pin Tool command 'Toggle Copper Pour Seed'
to set copper pour seedpoints
" Isolate all tracks [ Seed only from designated object

Net Attachment [ for none]: |— |

" Do Not Eill Beyond Obstacle Edge

Hatch Pattern.. | Comp Attachment.. |

oK Help | Cancel |

Figure 7: Edit Obstacle for Board Outline
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Click OK and then draw your board outline as shown in figure 8. You will need to
click on four corners of the obstacle, and then press ESC or left click and select “End
Command”.

_'ﬁllayout Plus —- E:\AKE',CMPE310_TA\TUTORIAL\LAYOUTEXAMPLE FILES'\CMPE310-1.MAX - [Design - Obstacle Tool {DRC OFF)]

2lEuil x|HE| 82|20 Qlw|of@ T(:o| offoxfe 54| Al ¢
X [-1250 [ [525 G [25 |0 Global Layer | -

Properties. .. Chrl+E
Copy Chrl+C
Delste Chrl+%

Finish
Segrent
Arc
Exchange Ends
{ 135's and 90's Cnly

Figure 8: Board Outline Obstacle

'JgraqTips:

- Press “I” for zoom-in and “O” for zoom-out, the center of zooming is the
position of the mouse. These shortcuts make it’s very easy to work on your
design.

- The size of board outline is an estimation of your board size, you can stretch it
after placing components.
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Placing components

You can either manually place components on the board or use auto placement

feature of Layout Plus. To manually place components, click on Component Tool ] on
the toolbar or go to Tool 2 Component = Select Tool. Place all components inside the
board outline.

For auto placement, first, you will need to preplace some of the components that
you want them to be placed on specific locations (ex. power connectors and headers).
Move the component to the desired location and then right click and select “Lock”™ or
press L. Figure 9 shows the preplaced and locked header before auto placement.

ﬂLarDut Plus -- E:\AKE,CMPE310_TA' TUTORIAL'LAYOUT" EXAMPLE FILES',CMPE310-1.MAX
File Edit WYiew Tool Options Auto ‘Window Help

clEn x|# E| 5220 QM OB T|c] «flxiel 24| 8]z ¢
% [100 v [3100 G [100 L ToP | ~|

%4 Design - Component Tool (DRC OFF)

End Command

Properties... Chrl+E
Copy Chrl+C
Delete Chrl+x

Shove il
Adjust Chrl+3
Mattix Place

Guick Place

Swap Chrl+w
Rotate R
Opposite T
Alternate Fookprint, ..

Make K
EBreak Chrl+K

Select Mext

Minimize Connections
Move OnfOff

Undo

Figure 9: Preplace components
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After preplace components, go to Auto = Place > Board. Layout plus will auto
place components within your board outline. Then you can adjust the board outline to a
proper size. Figure 10 shows the board after autoplaced.

&
S ES LA A A X L XXX L.
(1)
TIF.IOCsFO0:R ZOOsLI.D7T

TILEITE
A A R & & L 4L L

A A A A A A A LAAALALALALAL.

ug
BIF. 100 A0 H.a00s LT 07T
S08&M 1N

us

R XA R R R 2 2R L.

Figure 10: Board after autoplaced

- For a large PCB design, you might want to let Layout Plus autoplace your
components and then manually move some of the components to make your
board compact.

Thermal Relief and Plane Layers/Copper zones

Thermal relief pad provides a connection from pin or fanout to power and ground
plane layer or copper zone while minimize the heat transfer to plane during soldering. For
example, if you have 4-layer boards with power and ground planes, there will be thermal
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relief pads connect power and ground pins to power and ground planes. You can set the
size of thermal relief pad by go to Options > Thermal Relief Setting.

Routing the board

This section will show simple steps involved in autorouting. For manual routing,
please refer to Layout Plus Help. Before start routing, you need to assign plane layers to
power and ground net and disable routing for power and ground nets. First, go to View >
Database Spreadsheets = Nets. The nets spreadsheet dialog will show up, double click
on power net (VCC), uncheck “Routing Enabled” and then click on Net Layers
button. From Layers Enabled for Routing dialog, select the layer that you set to be used
as a power plane (ex. POWER) in “Plane Layers” box as shown in figure 11. Repeat the
same step for ground net (GND) except assign the other layer for ground plane (ex.
GND). After disable routing on power and ground nets and assign appropriate layers to
them, make sure that all other nets have a routing enabled attribute.

Edit Met

Net Name I'qrcc

Met Attributes

.| Routing Enabled

¥ Share Enabled [ Highlight

¥ Retry Enabled v Shove Enabled [” Test Point
T Layers Enabled for Routing |
eight
Group Iu Layers Enabled for Routing
|7 v TOP ¥ BOTTOM
Min WWidth |1 2 Conn Width
Plane Lay

ers
Net Layers... |7|- GND

Width By Laver...

0K | He

Figure 11: Disable routing and specify plane layer for power and ground net

0OK Help | Cancell

For SMT (Surface Mount Technology) board, you need to create fanout to
route a surface mount pad to via which provide a way to route from the pad layer to any
other layers. To create fanout, go to Auto = Fanout - Board. Skip this step if you are
working on through-hole board.
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Next step is to perform an autoroute, go to Auto > Autoroute > Board. The
result of this step is shown in figure 12.

Ui

T T Y Y tisnl inni

ng
oIF. D0 A0l . 6OdcLF. A7
=Rl =12, B )

- ABSessApesssssssesss

ur

YY1

Figure 12: Board after autorouting

'fgrl"CTips:

- Your can check each layer connection by turn on each layer display at a time,
first press Backspace to turn off all layers and then press key number
associated with each layer (ex. 0 for Global layer, 1 for TOP layer, 2 for
BOTTOM layer, 3 for GND layer, 4 for POWER layer and so on)

- To turn off one layer at a time, select the layer you want to turn off from the
toolbar (or press key associated with the layer) and then press — (minus sign)

- The key assigned to each layer is specified in Layer Spreadsheet
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Design Rules Check

To run DRC, go to Auto = Design Rules Check. You can select options you
want to be checked, DRC command will use system environment parameters that you
specified (or default values if you did not modify) as the design rules.

Print PCB layout

Go to File = Print/Plot, the dialog as shown in figure 13 will show up. You can
check the option “Print/Plot Current View” if you want to print only the layer(s) that
are being displayed.

Print/Plot |
— Printf{Plot Format ~Print{Plot Settings

Title: € [CMPE310 Project X Shift: o

" DXF Y Shift: ||]

& Print Manager

[~ Keep Drill Holes Open ] Tty o B I Miror
Print{Plot Current Yiew Scale Ratio: |1_ To: |1_
Sfack & Yvhite Rotation[CCW)
[~ Print/Plot To File |7F 0 <90 180 270

File Name:  lcmpe310-5.dxf

oK Help | Cancel |

Figure 13: Print/Plot Dialog

Post Process

Now, you should have a completed PCB design (with no error from DRC), next
you would want to generate the output files for PCB fabrication. The industry standard
file format for PCB fabrication is called Gerber files. These gerber files tell the machines
in PCB production process on how to draw patterns, make traces, drill holes and cut
board.

First, you need to set the post processor by go to Options = Post Process
Settings, from the dialog as shown in figure 14, you can choose the output format as
GERBER RS-274D or Extended GERBER (RS-274X) (depends on PCB manufacturer
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requirement). After set the post processor, go to Auto = Run Post Processor to generate

the output Gerber files.

Plot output Batch
File Name Enabled Device Shift
*TOP Yes EXTENDED GERBER Mo shift
*BOT Yes EXTENDED GEBBER MNo shift
* GND Yes EXTENDED GERBER Mo shift
* PWR Yes EXTENDED GERBER Mo shift
* IN1 Mo EXTENDED GERBER Mo shift
*IN2 Mo EXTENDED GEBBER MNo shift
*IN3 Mo EXTENDED GEBBER Mo shift
* IN4 Mo EXTENDED GERBER Mo shift
* ING Mo EXTENDED GERBER Mo shift
* ING Mo EXTENDED GEBBER MNo shift
*INT Mo EXTENDED GEBBER Mo shift
* ING Mo EXTENDED GERBER Mo shift
* IN9 Mo EXTENDED GERBER Mo shift
*1o Mo EXTENDED GEBBER MNo shift
*11 Mo EXTENDED GEBBER Mo shift
*12 Mo EXTENDED GERBER Mo shift —
* SMT Yes EXTENDED GERBER Mo shift
* 5B Yes EXTENDED GEBBER MNo shift
*5PT Mo EXTENDED GEBBER Mo shift
* SPB Mo EXTENDED GERBER Mo shift
*S5T Yes EXTENDED GERBER Mo shift
* 55B Mo EXTENDED GERBER Mo shift
*AST “es EXTENDED GEBBER Mo shift
* ASB Mo EXTENDED GERBER Mo shift
* DRD Yes EXTENDED GERBER Mo shift =
1] | v
Figure 14: Post Process Setting
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